It is currently Fri Aug 18, 2017 7:52 pm

All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Tue Aug 01, 2017 9:21 am 
Offline
Member
Member

Joined: Tue Aug 01, 2017 8:55 am
Posts: 1
Hello,

I have just begun to write an API in python to control the step motor card K8097 and used this link (http://www.velleman.eu/images/tmp/K8097_PROTOCOL.txt) as a general guideline.

After all I have some hard problems I am not able to solve:

- sending the comamnds "OUTPUT ON/OFF COMMAND" and "DEMO ON/OFF COMMAND", change nothing in the "STATUS COMMAND" i get from my the device. They seem to have no effect.

- also "SET TORQUE PER MOTOR COMMAND" and "RESET PER MOTOR COMMAND" seem to have no effect on the Status of the motors. In addition it seems that the bytesize of this command is wrong (PACKETSIZE should be 0b00001001 and not 0b00000101, if I am not wrong ...)

- I am only able to move the single motors if I send the "RESET PER MOTOR COMMAND" before the move command. Have you any idea of an Explanation for this behaviour?

I hope you can help me out with some of these questions.
Many thanks in advance.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: Bing [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group