It is currently Mon Aug 21, 2017 1:39 pm

All times are UTC




Post new topic Reply to topic  [ 12 posts ] 
Author Message
PostPosted: Tue Mar 14, 2017 1:46 pm 
Offline
Member
Member

Joined: Tue Mar 14, 2017 12:27 pm
Posts: 8
Should all step motors to be locked while K8200 is printing? I think they used to be tightly locked during the tests and printing.

I think all the axes must be lock-up during print operation, and so they were still yesterday. Starting from this morning Z-axis motor has not been locked and printing fails. Z-screw is released and free to rotate as soon as the layer change moves are made. I think this is why the layer thickness changes and finally the printer hangs, because the print head is too low.

I have changed the engine controls with each other, not the effect. Is it now so that the PCB is broken? Does anyone know what I should do?

This K8200 printer is still under warranty. It's only couple of weeks old. I've been in touch with the seller. He ask me to make a question at this board, if anyone knows the possible reason.

Thanks for your help in advance.


Top
 Profile  
 
PostPosted: Tue Mar 14, 2017 2:03 pm 
Offline
Senior Member
Senior Member

Joined: Tue Mar 27, 2007 12:24 am
Posts: 3431
Location: USA
I'm not sure I fully understand what you are asking.
When you adjusted the reference voltage for the drivers did you set them for 0.55 instead of 0.425?


Top
 Profile  
 
PostPosted: Tue Mar 14, 2017 3:02 pm 
Offline
Member
Member

Joined: Tue Mar 14, 2017 12:27 pm
Posts: 8
Thank you for your reply.

No I didn't. All motors used to work the same way and fully Ok even if the voltage was 0.425 V.
I raised voltage up to 0.49 V but it did not help or change anything.

What I mean is:
===========
1. When I used manual control for any axis, this axis motor got locked immediately.
2. You could not move the motor by hand freely without other actions.
The action is =>
3. You can release all motors by pressing the release-motors-button from Manual control panel.
===========

This has been the case on all direction motors and the extruder.

Since this morning Z-axis did not lock anymore. It runs as commanded but can not keep it's position because it's free to rotate as soon as it stops rotating. As soon as it stops it is free even if all the other axis motors stay locked until released by pressing the button.

Because the motor is free to rotate it do not stay in correct phase. It jumps either direction when control is taken by feeding power to the motor to run it again. This way it slowly loos the track and can be 0.5 mm too low on one layer only.

My printer Z-axis motor and the worm screw is so easily rotating that when it should stop turning it continues a step or couple further because there is no electrical brake effect to stop it exactly to the right step position. If I make a brake effect - by braking the rotation by hand - it stays in track because I keep it in right step point while the motor is waiting for the next instruction to turn.

There is a reason for this, but I ask you - the more experienced users - from what to start fixing the problem.


Last edited by Lepe on Tue Mar 14, 2017 3:27 pm, edited 1 time in total.

Top
 Profile  
 
PostPosted: Tue Mar 14, 2017 3:27 pm 
Offline
Senior Member
Senior Member

Joined: Tue Mar 27, 2007 12:24 am
Posts: 3431
Location: USA
I just tried mine.
The Z axis does not lock.
I don't think it ever did.
Most of the time when I start a print I watch the first layer.
If I don't like the way it is getting put down on the bed I will manually adjust it by turning the Z axis lead screw.
I don't think the Z axis will move that easily even though it's not locked.


Top
 Profile  
 
PostPosted: Tue Mar 14, 2017 5:23 pm 
Offline
Member
Member

Joined: Tue Mar 14, 2017 12:27 pm
Posts: 8
Thank you so much Wrong Way for your test and my problem investigation. It's so reassuring to know that Z-axis was NOT intend to be locked during the print process. This information leads me to the other problem solving solution and that is that I have to fix the Z-axis nut so that it's not that low friction and slippery.

It's funny that all other 3 motors get "brake current" as soon as you move it electronically. This "brake current" lasts couple of seconds and the motor gets different voltages between it's terminals starting about 2,5 V and up. Te only motor that do not get this what I call "brake current" is Z-axis in my K8200.

Background: The original Z-axis screw was so bent and inaccurate and the nut were so poor quality and loos fit that I decided to fix Z-axis. I went to the normal hardware store and bought a new 8 mm 1,75 pich RST screw ( 1 meter => 5,20 €). It's so high quality, it looks like jewel. Then I replaced the original nut with about 25 mm long tube nut. It compensates the rest of what the screw does not do 100 %. Final resolution is about 0,02 mm tolerance in moving up and back down. It runs like a dream but may be the reason of this all, even it has been running wonderfully for about 20 large objects before this morning and without any problem.

So what I expect now is that Z-axis screw/nut combination friction is too low. Motor's inertia runs the motor rotor a bit too glibly. I have to generate some kind of artificial friction, because my finger did this job quite well - as I mentioned. I do not want to loos Z-axis accuracy achieved so far.

This wasn't a wrong way to communicate and you Wrong Way can not believe how much I appreciate you quick and useful response.

Thank you and lucky 3D printings!


Last edited by Lepe on Thu Mar 16, 2017 8:18 am, edited 1 time in total.

Top
 Profile  
 
PostPosted: Tue Mar 14, 2017 9:57 pm 
Offline
Member
Member

Joined: Tue Jan 12, 2016 12:05 am
Posts: 49
Technicall an axis never "locks". Due to the motors being steppers, the last applied current is just being held to hold the stepper in position, which in turn then acts as a locking current.

There are several places in the firmware that can influence this.

One of them is in Configuration_adv.h:
Code:
//default stepper release if idle
#define DEFAULT_STEPPER_DEACTIVE_TIME 60
I'm not quite sure whether this is calculated for individual steppers, but it is most noticeable after moving an axis manually from the software, because for around 60seconds the motors will continue to buzz.


The other one is in Configuration.h:
Code:
// Disables axis when it's not being used.
#define DISABLE_X false
#define DISABLE_Y false
#define DISABLE_Z true
#define DISABLE_E false // For all extruders
I think this is, where your problem lies, because if one of these is set as "true" (it actually is the Z-Axis in the K8200 firmware), the default deactive time from above is not applied to this stepper, but it is turned off immediately, once the next few steps do have nothing to do for this stepper. To change this behaviour, you just have to change the flag to "false" and reupload the firmware to the printer.

There is a bit more to this: The firmware works in blocks. About the next 16 G-Code lines to print are already loaded into the printer memory and calculated. (the "look ahead feature" basically") The stepper is not deactivated if any of these 16 blocks contains a new step command for the axis. So if you have really small simple parts (hollow cube, for example) that already has a new z-step within the next 16 blocks, then the z-axis is not deactivated although the 15 lines of G-Code until then do not contain any changes in the Z-direction. That's why small calibration print may look better than final prints. It also may be a bit deceiving when moving the axis manually from the software, because if there are no next 16 lines of G-Code, it will not be deactivated, but turned off after the 60 seconds idle time mentioned above.
To be honest: It's beyond me, why this feature is there in the first place.


There is a third method that can influence it and this is the M84 G-Code command.
i.e. M84 S10 sets the idle time to ten seconds. Although I haven't seen it used yet, this G-Code can take flags (XYZE), so I'd assume that if supported by the firmware different idle times for the different axes can be applied. So just in case: Check your Start- and End-G-Code in Repetier (or whatever Software you use) for this one. It will probably appear without any flas as plain M84 in the End-G-Code - and this is about the only place where it's supposed to be.


Top
 Profile  
 
PostPosted: Thu Mar 16, 2017 3:44 am 
Offline
Member
Member

Joined: Tue Mar 14, 2017 12:27 pm
Posts: 8
I do love this kind of instructions.
So clear and easy to follow.
You must really know what you write here.

I bet this is my next phase of K8200 Z-axis stepper problem solving process.
I will start from option 3 th.
I promise to report here what are my test results.

It really sounded a very strange way of fixing this problem just by adding friction. Well it works but it's only a shortcut not the final solution.
Now I have lot more to test and think about.

Thank you Sverenja.


Top
 Profile  
 
PostPosted: Thu Mar 16, 2017 6:25 am 
Offline
Member
Member

Joined: Tue Mar 14, 2017 12:27 pm
Posts: 8
Good morning folks!

Can not find instructions for the following:
1. How to check an installed version of firmware? It is - can I read the firmware version from the board? (Even if it's an original version.)
2. How to ugrade K8200 firmware? (I've found several instructions but what to follow and not for K8400 etc.)
3. Does it matter if I use Win or Linux to update firmware?

Can somebody help me with this, please?

PS: G-code modification with M84 works, but it is not a solution for this problem.
It never help Z-axis to lock, it only takes care of releasing all axis step motors if they are locked in specified time.

PS: 1
    Working hard ;-) Now trying to install firmware by K8400 instructions.
    I hope this is the correct one:
    https://cdn-reichelt.de/documents/daten ... RMWARE.pdf
    Lubuntu Arduino's install didn't work. So I went to WIN laptop and Win-version seams to run as instructed.
    Let's see if compilation goes as expected.
    Lubuntu install also sucseeded. Was my mistake, nothing wrong with the skript.
    Compilation Ok.
PS: 2
    Everything on firmware modification & upload completed.
    The alteration was: #define DISABLE_Z true => #define DISABLE_Z false
    Test completed and the result was:
    Z-axis stepper motor gets lock ( eg. for M84 S10 gets lock on for 10 seconds) just the specified time.

This is it
    Today it has been a very interesting day. I learned more new things from 3D printer controlling then for a long long time before now().
    Thank you so much for your support. Without you instructions and help I never got this job done!

I will inform you here if this did not help my problem => Z-axis motor looses it's step phase.


Top
 Profile  
 
PostPosted: Thu Mar 16, 2017 2:07 pm 
Offline
Senior Member
Senior Member

Joined: Tue Mar 27, 2007 12:24 am
Posts: 3431
Location: USA
You can find the instruction for the K8200 firmware here
http://www.k8200.eu/manual/printing/?c=007
When upgrading the firmware use Arduino software 1.0.6 or lower you can download it from here.
https://www.arduino.cc/en/Main/OldSoftwareReleases#previous


Top
 Profile  
 
PostPosted: Thu Mar 16, 2017 9:56 pm 
Offline
Member
Member

Joined: Tue Mar 14, 2017 12:27 pm
Posts: 8
Hi!
Good news! K8200 is running now like a dream. Not the first Z-axis mistakes seen since firmware update.
I happen to install Linux version 1.0.5. It was Ok and update went well so I'm very happy.
Bye!


Top
 Profile  
 
PostPosted: Fri Mar 17, 2017 2:48 pm 
Offline
Senior Member
Senior Member

Joined: Tue Mar 27, 2007 12:24 am
Posts: 3431
Location: USA
Glad to hear your printer is back up and running.

Enjoy!


Top
 Profile  
 
PostPosted: Tue May 30, 2017 5:29 pm 
Offline
Member
Member

Joined: Tue Mar 14, 2017 12:27 pm
Posts: 8
Hello! One update for Z-axis control

I had to replace the fault main board and it seamed and I trusted that I do not require to update firmware for Z-locking because I having dual lead screws in Z-axis control. It means that Z-azis is not as free in rotation as it was with one screw only. Specially the driving belt makes some extra friction. I was wrong!

I found that printed parts are not in correct dimension of height. After lots of tests and calibrations I found that Z-axis works fine if there are only one simple part but if there are several Z-axis up and down move leads in trouble and part height starts to lower and lower what more parts what more complicated they are.

I had to update Z-axis locking and surprise surprise the dimensions are Ok again.

I wonder why this firmware originally is set as Z-axis lock false? If you have any problems with part high dimensions I recommend firmware update as instructed before.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group