It is currently Sun Jul 23, 2017 12:40 am

All times are UTC




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Sun Jul 16, 2017 11:35 am 
Offline
Member
Member

Joined: Sun Jul 16, 2017 11:17 am
Posts: 4
Hi everyone,

After printing ABS for a while (most of the time it failed), I thought it was time to add a heated bed to my vertex k8400.
I bought a mk3 alu heated printbed, and I attached it with a self-made power expander to an external 12v PSU.
Then I noticed that the heated bed wouldn't turn of, so I resoldered the power expander twice, but it didn't help.
I then noticed that the heat bed LED indicator is always on, I checked it with external LEDs and it turned out that
the heated bed output on the main board is always turned on...
I tried re-uploading the firmware but it didn't help.
Have you got any solutions?

Alfredias


Top
 Profile  
 
PostPosted: Mon Jul 17, 2017 5:43 am 
Offline
Member
Member

Joined: Wed Aug 19, 2015 5:48 am
Posts: 15
Location: Croatia (Hrvatska) ,Zagreb
The Marlin firmware the ‘Configuration.h’ file has a line that need
to be changed for the type of thermistor used

https://dl.dropbox.com/s/gsx5zu130azuno ... 3.pdf?dl=0


Top
 Profile  
 
PostPosted: Mon Jul 17, 2017 8:20 am 
Offline
Member
Member

Joined: Sun Jul 16, 2017 11:17 am
Posts: 4
Thanks, but I don't think that the thermistor is the problem,
When I plugged the thermistor in it was immediatly recognized and it showed a good temperature reading (the same as the thermistor in the hotend).
The problem is that the heated bed output is always on, no matter what.
When I stop the heated bed in repetier host, it still stays on....
When I unplug the thermistor, the heatbed still stays on....
When I reboot the 3d printer, the heatbed still stays on....

Alfredias


Top
 Profile  
 
PostPosted: Mon Jul 17, 2017 2:09 pm 
Offline
Member
Member

Joined: Wed Aug 19, 2015 5:48 am
Posts: 15
Location: Croatia (Hrvatska) ,Zagreb
Did you make any changes to Marlin firmware the ‘Configuration.h’ file has a line that need
to be changed ? and the Start and End G–code in Cura
according to instructions in link ?

If it is well set, problem is that Power Expander or signal from Motherboard (bad conection)


Top
 Profile  
 
PostPosted: Mon Jul 17, 2017 2:25 pm 
Offline
Member
Member

Joined: Sun Jul 16, 2017 11:17 am
Posts: 4
I didn't make any changes to the marlin firmware, because the thermistor I use is the same as in the hotend, so it was
immediatly recognized and gave a good temperature reading. I know that the connection to the power expander is also not the problem because the LED on the mainboard is always on, which indicates that the output of the heatbed on the mainboard is also always on...


Top
 Profile  
 
PostPosted: Mon Jul 17, 2017 3:37 pm 
Offline
Member
Member

Joined: Wed Aug 19, 2015 5:48 am
Posts: 15
Location: Croatia (Hrvatska) ,Zagreb
I think you still have to make changes to the software because it's about power management instead of a thermistor, try it can always reset the settings to the old one, try it according to the instructions

http://www.k8xxx-3dprinters.crimed.be/w ... heated_bed

Here is topic:
viewtopic.php?f=64&t=14714


Top
 Profile  
 
PostPosted: Mon Jul 17, 2017 5:02 pm 
Offline
Member
Member

Joined: Sun Jul 16, 2017 11:17 am
Posts: 4
I made the changes to the firmware and the slicer, but it didn't work.
I guess the problem is in the hardware and not in the software, since the firmware should be able to turn the heatbed on and off without making any changes to it....


Top
 Profile  
 
PostPosted: Mon Jul 17, 2017 6:23 pm 
Offline
Member
Member

Joined: Wed Aug 19, 2015 5:48 am
Posts: 15
Location: Croatia (Hrvatska) ,Zagreb
That it is probably a power expander


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group